WordPress 5 et Woocommerce : ça se complique (ou pas)

0

Wordpress 5 est repoussé pour le 27 novembre 2018. Et Woocommerce vient de passer en version 3.5.1. L'air de rien, ces upgrades risquent de faire mal. Tester localement s'avèrera indispensable avant toute mise à jour

Tic Tac Tic Tac … J-9 avant la nouvelle mouture RC de WordPress, mise à jour majeure puisque l’on changera de numéro de version. Exit donc la version 4 et hello la V5 et son fameux éditeur Gutenberg …

En parallèle, Woocommerce est passé de la v 3.4.x à la version 3.5.x. Un changement mineure normalement, avec une rétro-compatibilité avec toutes les versions Woocommerce 3. Mais ça, c’est en théorie. En pratique, c’est tout autre. Tout d’abord, la team de WooCommerce a mis à jour plusieurs de ses plugins pour fixer des problèmes de compatibilités avec le version 3.5.X. Et à ce jour, de nombreux éditeurs de plugins ne ce sont pas encore donné cette peine. Y compris des plugins de paiement en ligne « Officiels » de plusieurs banques française (mais pas que) dont je tairais le nom.

J’en ai contacté plusieurs ces derniers jours, et les réponses sont … inquiétantes. En gros, plusieurs éditeurs n’ont tout simplement pas préparé cela, et attendent de voir ce qu’il se passera, en promettant, le cas échéant, de fournir des correctifs si nécessaires … à 199$ par an, on s’attend à un peu mieux.

Ce genre de comportement paralyse toute la chaine de mise à jour. Si un seul de vos plugins n’est pas compatible, vous êtes obligés de revenir en arrière, revenir à Woocommerce 3.4.X, downgrade de certains de vos plugins, etc …

WordPress 5 nécessiterait Woocommerce > 3.5.1

Mais que vient faire WordPress 5 là-dedans me direz-vous ? Et bien le 31 octobre dernier, Woocommerce 3.5.1 était publié. Une version anodine, avec des correctifs et fix pour Gutenberg par exemple. Mais surtout une petite phrase qui fait réagir :

Important: If you will be using WordPress 5.0, you should also be using WooCommerce 3.5.1+.

la faute à un nouveau filtre pour Gutenberg: use_block_editor_for_post

Avec WordPress 5, Woocommerce 3.5.1 devrait devenir la version minimale requise(bien qu’à ce stade, rien n’indique qu’il ne soit pas possible d’utiliser une version antérieure de WC). Et c’est là que tout peut s’effondrer, comme des dominos … ou pas … Qui plus est, les mise à jours majeures sont souvent la cause de bugs qui nécessiteront de nombreux correctifs et une version 5.0.1 assez rapidement.

Que faire ?

Et bien plusieurs cas de figure sont envisageables:

  • Vous avez déjà fait la mise à jour vers WooCommerce 3.5.1 et tout se passe bien : Dans ce cas, mettre à jour vers WordPress 5 devrait aussi bien se passer.
  • Vous avez fait la mise à jour vers WooCommerce 3.5.1 et rencontrez des difficultés :
    • Si ces difficultés sont mineures, et/ou causées par un seul plugin non indispensable : Désactivez ce plugin et contacter l’auteur du plugin. Puis attendez un correctif pour réactiver le plugin en question.
    • S’il s’agit d’un problème majeur, ou d’un plugin indispensable (paiement en ligne), revenez à une version inférieure à la 3.5. A ce jour, il s’agit de la version 3.4.7. Vous pouvez obtenir cette version sur le repo WordPress : https://fr.wordpress.org/plugins/woocommerce/advanced/ et choisir en bas de la page la version désirée.
  • Vous n’avez pas encore fait les mises à jour et êtes toujours sur une version inférieure à WooCommerce 3.5:
    • Testez votre site localement sur votre ordinateur. Vous pouvez utiliser VVV pour configurer un environnement de test sur votre ordinateur (Windows, Linux ou Mac).
    • pensez à vérifier les paiements, les renouvellement d’abonnements, la mise en place des droits pour les membres, etc …
    • Attendez : Ne vous précipitez pas sur la version 5 de WordPress. Attendez le premier correctif de Wp (surement la version 5.0.1). Cela laissera le temps à tous les dev de fixer leurs plugins, et à la team WP de fixer les bugs introduits par la nouvelle mouture WP
      • Durant cette phase, je vous conseille de bloquer toutes les mises à jour (sauf si correctif important de sécurité).

Paranoia ?

Oui et non. En règle général, je fais plutôt confiance aux éditeurs de plugins, qui sont réactifs et anticipent ces mises à jours. Mais les réponses de certain éditeurs de plugin m’ont laissé pantois. Et comme plusieurs d’entre eux fournissent des version officielles et recommandées par les banques de plugins de paiement par carte bancaire, j’ai décidé de creuser un peu. Et je me suis rendu compte que d’autres plugins importants n’étaient pas encore garanti comme compatible (ni même testé avec) Woocommerce 3.5.1 et WordPress 5, alors même que des version de tests pour les développeurs sont disponibles.

Je ne critique pas les développeurs, j’en fais partie, et en tant que petit développeur à titre perso, je n’ai pas non plus le temps de tout vérifier. Mais quand des plugins ont été téléchargés des centaines de milliers de fois, et qu’en plus il faut payer 199$ par an pour les mises à jour, là c’est inadmissible.

Dans tous les cas, vous avez le temps. La sortie officielle a été repoussé du 19 au 27 novembre 2018.



Recevoir la newsletter

Recevoir la newsletter

Recevez les dernières news et astuces Wordpress & Développement Web par email une fois par semaine

Bravo, vous êtes inscrits